Test for membership should be 'not in' (E713)
Tests for membership should use the form x not in the_list
rather than not x in the_list
. The former example is simply more readable.
Anti-pattern
my_list = [1, 2, 3]
if not num in my_list:
print(num)
Best practice
my_list = [1, 2, 3]
if num not in my_list:
print(num)